tests/testthat/test-assumptions.R

test_that("documentation regarding desc is still accurate", {
  skip_on_cran()
  versions <- versions::available.versions("desc")
  if (max(as.package_version(versions$desc$version)) > "1.2") {
    rlang::abort("newer version of desc on CRAN. Adapt the warning and maybe add minimal version requirement?")
  }
})

Try the precommit package in your browser

Any scripts or data that you put into this service are public.

precommit documentation built on Oct. 23, 2020, 6:18 p.m.