README.md

Installation

Currently you can only install spector from GitHub, there are two methods to do this:

Installing using Bioconductor

The first step is to check you have the Bioconductor release 3.4 or higher. To do that run:

source("https://bioconductor.org/biocLite.R")
biocLite()

This will tell you the version of Bioconductor and ask you to update if necessary. If you are having trouble updating please see the instructions to troubleshoot.

The next step is to install the package with all dependencies and vignettes.

source("https://bioconductor.org/biocLite.R")
library(devtools)
biocLite("anasrana/spector", dependencies = TRUE,  build_vignettes = TRUE)

Manually install dependencies

The other option is to use devtools to install the package with CRAN dependencies and to install Bioconductor dependencies manually.

Bioconductor dependencies

Versions required in brackets

Installing package

library(devtools)

install_github("anasrana/spector", 
               dependencies = TRUE, build_vignettes = TRUE, ref = "v0.8") 

Troubleshooting

Below is information compiled from the Bioconductor homepage, more information can be found here

If some of the Bioconductor packages won't update or you are seeing a message like this:

BiocInstaller version 3.2 is too old for R version 3.3

you have to take the following steps:

R remove.packages("BiocInstaller") source("https://bioconductor.org/biocLite.R") biocValid()

If all steps are completed successfully go back to the installation



anasrana/spector documentation built on May 14, 2019, 2:36 p.m.