R/onLoad.R

Defines functions onLoad

.onLoad <- function(libname, pkgname) {
  .jpackage(pkgname, lib.loc = libname)
  if(J("java.lang.System")$getProperty("java.version") < "1.8.0") {
    stop("rMARC requires Java >= 1.8 ", call. = FALSE)
  }  
  .jinit()
}
kliegr/marc documentation built on May 18, 2017, 9:40 p.m.