README.md

fpp3

CRAN
status R build
status Downloads

Overview

The fpp3 package contains data used in the book Forecasting: Principles and Practice (3rd edition) by Rob J Hyndman and George Athanasopoulos. It also loads several packages needed to do the analysis described in the book. These packages work with the tidyverse set of packages, sharing common data representations and API design.

Installation

You can install the stable version from CRAN.

install.packages('fpp3', dependencies = TRUE)

You can install the development version from Github

# install.packages("remotes")
remotes::install_github("robjhyndman/fpp3-package")

Usage

library(fpp3) will load the following packages:

You also get a condensed summary of conflicts with other packages you have loaded:

library(fpp3)
#> ── Attaching packages ──────────────────────────────────────────── fpp3 0.4.0 ──
#> ✓ tibble      3.0.6          ✓ tsibble     0.9.4     
#> ✓ dplyr       1.0.3          ✓ tsibbledata 0.2.0.9000
#> ✓ tidyr       1.1.2          ✓ feasts      0.1.6.9000
#> ✓ lubridate   1.7.9.2        ✓ fable       0.3.0     
#> ✓ ggplot2     3.3.3
#> ── Conflicts ───────────────────────────────────────────────── fpp3_conflicts ──
#> x lubridate::date()    masks base::date()
#> x dplyr::filter()      masks stats::filter()
#> x tsibble::intersect() masks base::intersect()
#> x tsibble::interval()  masks lubridate::interval()
#> x dplyr::lag()         masks stats::lag()
#> x tsibble::setdiff()   masks base::setdiff()
#> x tsibble::union()     masks base::union()


Try the fpp3 package in your browser

Any scripts or data that you put into this service are public.

fpp3 documentation built on Feb. 6, 2021, 9:14 a.m.