iam_get_policy_version: Retrieves information about the specified version of the...

Description Usage Arguments Details Request syntax

View source: R/iam_operations.R

Description

Retrieves information about the specified version of the specified managed policy, including the policy document.

Usage

1
iam_get_policy_version(PolicyArn, VersionId)

Arguments

PolicyArn

[required] The Amazon Resource Name (ARN) of the managed policy that you want information about.

For more information about ARNs, see Amazon Resource Names (ARNs) and AWS Service Namespaces in the AWS General Reference.

VersionId

[required] Identifies the policy version to retrieve.

This parameter allows (through its regex pattern) a string of characters that consists of the lowercase letter 'v' followed by one or two digits, and optionally followed by a period '.' and a string of letters and digits.

Details

Policies returned by this API are URL-encoded compliant with RFC 3986. You can use a URL decoding method to convert the policy back to plain JSON text. For example, if you use Java, you can use the decode method of the java.net.URLDecoder utility class in the Java SDK. Other languages and SDKs provide similar functionality.

To list the available versions for a policy, use ListPolicyVersions.

This API retrieves information about managed policies. To retrieve information about an inline policy that is embedded in a user, group, or role, use the GetUserPolicy, GetGroupPolicy, or GetRolePolicy API.

For more information about the types of policies, see Managed Policies and Inline Policies in the IAM User Guide.

For more information about managed policy versions, see Versioning for Managed Policies in the IAM User Guide.

Request syntax

1
2
3
4
svc$get_policy_version(
  PolicyArn = "string",
  VersionId = "string"
)

paws.security.identity documentation built on Oct. 30, 2019, 11:26 a.m.