mem_function_notes.md

Keep track of igraph-related functions that call other functions

subsetCnetIgraph()

spread_igraph_labels()

reorderIgraphNodes()

Re-consider function name style

Re-consider whether renaming functions with some consistent and intuitive naming scheme could be beneficial. I actually complain about my own inconsistency so I think it best to rename functions sooner than later. Old functions will be deprecated and aliased to the new function names.

Function Style Option A: type_verb_subtype()

For me it is sometimes helpful to see the relevant object type first in the function name, however this style may not be idea. For example:

Function Style Option B: verb_type_subtype()

This option is preferred because it matches Tidyverse convention

A counter point, the tidyverse style guide suggests using verbs, all lowercase with underscore '_' between words (not camelCase). For example:

New alternate function subset_igraph()?

Instead of:

One common function:

- or prune_igraph() or filter_igraph() * remove_singlets=FALSE * remove_blanks=FALSE

Tidyverse %>% and R-4.1 > pipe compatibility

Where possible and where relevant the functions should be compatible with tidyverse pipe %>% and the new R-4.1 operator pipe \>

In practice when functions are called for their side-effects, the function should return the same object supplied after applying modifications.

Finding relevant functions

For convenience one can use jamba::grepls("igraph.") to find functions relevant to igraph objects.



jmw86069/multienrichjam documentation built on Feb. 7, 2024, 12:58 a.m.